HTTP स्थिति वाक्यांश से कोड लुकअप

इसका संख्यात्मक स्थिति कोड ज्ञात करने के लिए HTTP कारण वाक्यांश दर्ज करें।

इसका उपयोग कैसे करें

  1. ऊपर दिए गए फ़ील्ड में अपने मान दर्ज करें।
  2. तुरंत परिणाम देखने के लिए परिकलित करें पर क्लिक करें।
  3. अपने परिणाम का लिंक कॉपी करने के लिए साझा करें बटन का उपयोग करें।

इस कैलकुलेटर के बारे में

RFC 9110 (और इसके पूर्ववर्ती RFC 7231 तथा RFC 2616) में परिभाषित हर HTTP स्थिति कोड तीन-अंकों के संख्यात्मक कोड को एक मानक कारण वाक्यांश के साथ जोड़ता है — “200 OK”, “404 Not Found”, “502 Bad Gateway” — और यह टूल उलटी लुकअप करता है: वाक्यांश टाइप करें (अक्षर-रूप मायने नहीं रखता), और कोड तथा उसकी श्रेणी पाएँ, जो उस सैकड़े के रूप में दिखाई जाती है जिससे वह संबंधित है — 1xx Informational, 2xx Success, 3xx Redirection, 4xx Client Error, 5xx Server Error। यह मानक पंजीकृत वाक्यांशों को कवर करता है, जिनमें “418 I'm a Teapot” और “429 Too Many Requests” जैसे कम आम वाक्यांश भी शामिल हैं, लेकिन यह पुराने नाम “Payload Too Large” (413) और “Unprocessable Entity” (422) पहचानता है, RFC 9110 के नए शब्दांकन “Content Too Large” और “Unprocessable Content” को नहीं।

बैकएंड डेवलपर, API डिज़ाइनर और DevOps इंजीनियर इसे तब काम में लाते हैं जब किसी लॉग लाइन या त्रुटि संदेश में केवल वाक्यांश दिखता हो, API दस्तावेज़ लिखते समय, या यह तय करते समय कि नए एंडपॉइंट से कौन-सी कोड श्रेणी लौटानी है — यह जानना कि कोई वाक्यांश 400 की श्रेणी में आता है, तुरंत सर्वर की खराबी के बजाय क्लाइंट-पक्ष की समस्या का संकेत देता है, जिससे बदलता है कि मॉनिटरिंग और अलर्टिंग को उसे कैसे लेना चाहिए।

क्या यह उपयोगी था?

आप अधिकतम 3 प्रतिक्रियाएँ चुन सकते हैं।

टिप्पणियाँ

  • सबसे पहले टिप्पणी करें।

लोकप्रिय कैलकुलेटर

सभी कैलकुलेटर